Labels

Wednesday, November 16, 2005

New Macs Require Final Cut Pro 5

Final Cut Pro 4.5 HD and earlier not supported on Power Mac G5 (Late 2005) or iMac G5 (iSight).
Final Cut Pro 4 through Final Cut Pro HD 4.5 won't work on the new iMac G5 (iSight)

From the Los Angeles Final Cut Pro Users Group (LAFCPUG):

Over at xlr8yourmac.com they have a first impression report from a new Quad G5 Mac owner. He likes is. He REALLY likes it.

No comments:

Post a Comment